Arhiv Značk: računalništvo

Mikrotik VPN IPsec+L2TP

Skratka z novimi posodobitvami za IOS in MAC os je Apple izločil navaden VPN, ki sicer še vedno deluje na Microsoft gajbicah. Kakorkoli za pridobitev SLO IP + ostale zadeve sem bil primoran nastaviti nov VPN. Odločil sem se za IPsec+L2TP, ki naj bi bil precej varen. Ne bom razglabljal v detajle….zopet ti pomagam spraviti zadevo skupaj. Najprej sem pogledal navodila na mikrotik strani in se izgubil: http://wiki.mikrotik.com/wiki/Manual:IP/IPsec#Apple_iOS_.28iPhone.2FiPad.29_Client

V “” so ukazi ali podatki, ki jih moraš prirediti za svoj router.
Ok….kakor že poznano sem uporabil remote dostop preko SSH:

Če se boš povezoval preko SSH je ukaz sledeči:  ssh “user”@”ip mikrotik

Najprej omogočimo L2TP server:
/interface l2tp-server server
set authentication=mschap2 enabled=yes

oz. tokrat bo lažje klikati preko browserja. Poiščeš PPP>interfaces>L2TP server.
enabled – DA
Default profile – ipsec+L2TP
Authentication – mschap2
Use IPsec – DA
IPsec Secret “vneseš neko geslo, ki se ga zapomni saj ga boš kasneje moral vnesti na klientu, ki se povezuje na VPN – imenuje se SECRET

PPP>Profiles >Add New
name: “ipsec+L2TP”
Local Address: “IP tvojega routerja”
Remote Address: ipsec-pool (ga skreiramo v naslednjem koraku, zato moraš priti nazaj popraviti zadevo)
DNS Server:  “IP tvojega routerja”
Change TCP MSS: yes
Use Encryption: yes
ostalo pustiš na default
Comment: ipsec+L2TP

IP>pool>Add new
Name: ipsec-pool
Adresses: “192.168.x.120-192.168.x.122” – poljubno, vsekakor pa iz ranga DHCP

PPP>secrets>Add new
enabled – DA
Name: “uporabniško ime” – se ga zapomni, saj ga boš kasneje moral vnesti na klientu, ki se povezuje na VPN.
Password: “geslo” – se ga zapomni, saj ga boš kasneje moral vnesti na klientu, ki se povezuje na VPN.
Service: l2tp
Profile: ipsec+L2TP
Comment: “ipsec+L2TP secret”

Nadaljujemo z konfiguracijo IPsec:
poiščeš levo IP>IPsec>Groups
Name: ipsec+l2tp

v zavihku zraven Groups poiščeš Proposals
uredil sem kar default, ki je že obstajal in sicer:
Enabled – DA
Auth. Algorithms – sha1
Encr. Algorithms – 3des, aes-128 cbc, aes-256 cbc

v zavihku zraven Proposals poiščeš Peers>Add New
Enabled – DA
Address: 0.0.0.0/0
Secret – vneseš isto geslo, kot zgoraj za  – “SECRET”
Exchange Mode – main l2tp
Send Initial Contact – DA
NAT Traversal – DA
Proposal Check – obey
Hash Algorithm – sha1
Encryption Algorithm: aes-192, aes-256, 3des, aes-128
Generate Policy – izbereš port-strict

v zavihku zraven Peers poiščeš Policies in Add New
Enabled – DA
Src. Address: 0.0.0.0/0
Dst. Address: 0.0.0.0/0
Protocol: 17 (udp)
Template: DA
Group: ipsec+l2tp
Action: encrypt

Skoraj smo na koncu. Potrebno je še skonfigurirati požarni zid.
IP>firewall>Add New
dodamo tri iste, razlike so samo v dst. port, ki so 500, 1701, 4500.
enabled – DA
Chain – input
Protocol – 17 (udp)
Dst. port (500, 1701, 4500)
In. interface: ether 1
action: accept
Comment: VPN

In že lahko skonfiguriraš klienta. Spišem v kratkem navodila še za to.

Če ugotoviš izboljšave ali napake pa me prosim kontaktiraj.

T2 TV na Mikrotik

Že pred leti sem si nabavil prvi Mikrotik router, ki je seveda prava raketa, razen konfiguracija. Pred kratkim sem ugotovil, da deluje tudi terminal iz apple terminal zadevščine, kar me je sploh razveselilo.

Ok se bom poizkusil prebiti skozi kako nastaviti T2 TV na Mikrotiku. Namreč po defaultu je mikrotik router nič drugega kot navadno stikalo oz. zarukana škatlica. Kar me ni motilo, saj je to vodilo k res dobremu routerju. Naj priznam, da sem prebrskal precej interneta in prišel do polovice podatkov, šele z Gregorjem K. mi je zadevo uspelo speljati do delujoče.

nekaj virov na internetu:
https://slo-tech.com/forum/t535833
https://slo-tech.com/forum/t681411
http://nejc.suhadolc.si/igmp-proxy/
https://www.virtua-it.si/201201igmp-proxy-drugic/
http://wiki.mikrotik.com/wiki/Manual:Routing/IGMP-Proxy
http://www.internetmojster.com/racunalnistvo/deljenje-ip-televizije.html

Ok…povezava na router je mogoča tudi preko browserja….oz. v mojem primeru preko SSH.

Omrežje, ki ga imam pa je sledeče (nekaj podobnega imaš gotovo tudi doma). Optično stikalo T2 Milan in na katerikoli port obesiš mrežni kabel do vtičnice 1 na Mikrotiku – WAN. Od tu pa seveda po drugem kablu do računalnika – LAN (v mojem primeru do Mac-a) in potem sem uporabil odprto kodni projekt Kodi za gledanje T2 TV nanj. Namreč nimam T2 škatlice za ogled TV + daljinca. Pogoj da tole deluje je naročena vsaj osnovna T2 TV shema. Še opomba, poizkusil sem tudi preko Wi-FI kjer zadeva sicer deluje, ampak zaradi počasnosti wi-fi-ja je zadeva čisto neuporabna.

V “” so ukazi ali podatki, ki jih moraš prirediti za svoj router.
Če se boš povezoval preko SSH je ukaz sledeči:  ssh “user”@”ip mikrotik

Pod interfaces moraš pogledati kako imaš nastavljena dva parametra. Potrebuješ točno ime za WAN, npr. ether1 in LAN npr. ether2-master in potrebuješ še ime za bridge.

Urediš nastavitve za IGMP proxy
/routing igmp-proxy interface
add alternative-subnets=172.16.0.0/12 disabled=no interface=ether1 threshold=1 upstream=yes
add disabled=no interface=ether2-master threshold=1 upstream=no
add disabled=no interface=bridge threshold=1 upstream=no

sedaj se postavi z ukazom na pozicijo:
/routing igmp-proxy interface  

ukaz print pa ti mora izpisati tole:

Flags: X – disabled, I – inactive, D – dynamic, U – upstream

 #    INTERFACE                                        THRESHOLD                                                                                                                           

U ;;; T2 TV

ether1                                                       1

1    ;;; T2 TV

ether2-master                                       1

2    ;;; T2 TV

bridge-local                                           1

V kolikor imaš drugače nekaj nisi pravilno nastavil!

Nastavitve požarnega zidu:
/ip firewall filter
add action=accept chain=input comment=”Dovoli Broadcast” disabled=no dst-address-type=broadcast place-before=0

add action=accept chain=input comment=”Dovoli IGMP” disabled=no protocol=igmp place-before=0
add action=accept chain=input comment=”Dovoli T-2 IPTV” disabled=no protocol=udp src-address=172.16.0.0/12 place-before=0

In voila slika se mora prikazati….V kratkem spišem še kako deluje Kodi z T2 TV. Če ugotoviš izboljšave ali napake pa me prosim kontaktiraj.

Update: navodila T2 TV preko KODI s pomočjo Mikrotik routerja.

WordPress leti

Wau….pred mnogimi leti sem pričel z prvim CMS-om….niti ne vem kaj točno je bil…Kaj kmalu sem pričel z Joomlo, ki je še danes prava raketa in jo res precej dobro poznam.

No pred leti, ko sem postavil tale blog pa sem se odločil za WP, ker je takrat veljal za bloganje. Z leti je prišel daleč naprej, blizu joomle in jo celo prekaša v marsikateri zadevi…

Danes so me presenetili z novo verzijo….in ja, kot vidim zna že wp kar sam iz URL linka integrirati tudi video….joomla kaj takega še ne zna…1:0 za wordpress 😉

Google rankiranje

Če sem pred kakima dvema letoma pisal temo na google rangiranje….bi jo lahko danes ponovno.

Takrat sem se ukvarjal kako priti na prvo mesto za zadetek Dive Bled….

Danes pa se ukvarjam kako priti na prvo mesto: ZAČETNI POTAPLJAŠKI TEČAJ 😉
Skratka po vpisu v google: ZAČETNI POTAPLJAŠKI TEČAJ konkurenca prehiteva moje željene strani. Pa vseeno prednjačijo zadetki z FB; dočim moji zadetki po raznih straneh se nahajajo šele na tretji google strani in sicer:

  • ta blog je neverjetno prvi, kar kaže na očitno dobro avto optimizacijo WP-a;
  • sledi PADI ZAČETNI POTAPLJAŠKI TEČAJI z moje klubske strani;
  • stran 4 pa presenetljivo dviguje rang iz nekje ozadaj spletka oglasi.si

Preseneča pa me dejstvo, da prvi zadetek na google takoj za glavno domeno gosti tole:

  • tecaji-potapljanja/rekreativno-padi/zacetni-potapljaski-tecaj-owd/
  • za razliko od moje strani: padi-potapljaski-tecaji/padi-zacetni-potapljaski-tecaji/zacetni-potapljaski-tecaj-open-water-diver.html

Hudiča mojega zadetka sploh ni na goolge med prvimi 5imi stranmi….kje torej tišči vzrok?

Očitno v tem, da zadetki v google na PADI ZAČETNI POTAPLJAŠKI TEČAJ spremenijo šah pozicije:

  • na prvem mestu je še vedno isti konkurent – tecaji-potapljanja/rekreativno-padi/zacetni-potapljaski-tecaj-owd/
  • na drugi strani se nahaja moj page
  • za njim takoj pa tale blog

Dokaj slabo rangiranje….nekako do prvih dveh strani je vse ok….
Ok kako google rangira ve sam bog in google strokovnjaki….;)

Tudi pregled google addwords ne  pokaže kakih ogromnih zadetkov na iskalne besede….mogoče je v tem fora, da ni kaj dosti iskano na področju Slovenije v smislu: padi-zacetni-potapljaski-tecaj?

Pregledam rang čez kak mesec….pa se spet kaj razpišem…..;)

O meni

matjaz repnik – prijatelji so vedno okrog mene 😉

Ukvarjam (zanima me) se z: