Arhiv Značk: t2tv

T2 TV preko KODI s pomočjo Mikrotik routerja

V preteklem tednu sem spisal kako spraviti T2 TV preko Mikrotik routerja, sedaj pa je čas, da spišem še oz. povem skrivnost kako T2 TV predvajati na kompjutru. Pogoj, da ti deluje T2 TV na računalu je, da imaš naročeno vsaj osnovno TV shemo z okrog 50 programi. Na računalniku jih je v času pisanja vsaj 400. T2 TV ne deluje na Wi-Fi oz. izredno kocka sliko zaradi slabega prenosa wifi.

Počasi….

  • Najprej inštalacija, ker pa so določene zadeve že spisali bom samo prilepil linke.
  • KODI je seveda tudi predvajalnik filmov in obenem downloader podnapisov. Svojo funkcijo obvlada in je res super zadeva.
  • T2 TV na KODI. Oddaljena pot za T2 M3U listo.
    Oddaljena pot za logotipe. EPG pa dobiš s privatnim sporočilom.
  • Seveda KODI ja upravljamo tudi z daljincem. Dodam navodila kako usposobiti še to.

Odpreš kodi in greš SISTEM>NASTAVITVE>SPLETNI STREŽNIK. Označiš “Dovoli oddaljen nadzor preko HTTP. up ime in geslo pa nastaviš kot želiš, potrebno se ga je le zapomniti.

Ker uporabljam iPhone bom napisal navodila zanj. Greš na iStore in vpišeš KODI. Prvi zadetek je Offical Kodi Remote, ki je brezplačen.

Zaženeš remote…Sedaj je pomembno, da sta KODI in iPhone na istem wi-fi/kabel omrežju. Spodaj levo imaš add host>Find Kodi. Poišče ga kar sam, vneseš le še uporabniško ime in geslo in VOILA gremo…ane Uroš….ti je uspelo?

 

Update september 2017: http://matjaz.repnik.eu/2017/09/01/t2-in-kodi/ 

 

T2 TV na Mikrotik

Že pred leti sem si nabavil prvi Mikrotik router, ki je seveda prava raketa, razen konfiguracija. Pred kratkim sem ugotovil, da deluje tudi terminal iz apple terminal zadevščine, kar me je sploh razveselilo.

Ok se bom poizkusil prebiti skozi kako nastaviti T2 TV na Mikrotiku. Namreč po defaultu je mikrotik router nič drugega kot navadno stikalo oz. zarukana škatlica. Kar me ni motilo, saj je to vodilo k res dobremu routerju. Naj priznam, da sem prebrskal precej interneta in prišel do polovice podatkov, šele z Gregorjem K. mi je zadevo uspelo speljati do delujoče.

nekaj virov na internetu:
https://slo-tech.com/forum/t535833
https://slo-tech.com/forum/t681411
http://nejc.suhadolc.si/igmp-proxy/
https://www.virtua-it.si/201201igmp-proxy-drugic/
http://wiki.mikrotik.com/wiki/Manual:Routing/IGMP-Proxy
http://www.internetmojster.com/racunalnistvo/deljenje-ip-televizije.html

Ok…povezava na router je mogoča tudi preko browserja….oz. v mojem primeru preko SSH.

Omrežje, ki ga imam pa je sledeče (nekaj podobnega imaš gotovo tudi doma). Optično stikalo T2 Milan in na katerikoli port obesiš mrežni kabel do vtičnice 1 na Mikrotiku – WAN. Od tu pa seveda po drugem kablu do računalnika – LAN (v mojem primeru do Mac-a) in potem sem uporabil odprto kodni projekt Kodi za gledanje T2 TV nanj. Namreč nimam T2 škatlice za ogled TV + daljinca. Pogoj da tole deluje je naročena vsaj osnovna T2 TV shema. Še opomba, poizkusil sem tudi preko Wi-FI kjer zadeva sicer deluje, ampak zaradi počasnosti wi-fi-ja je zadeva čisto neuporabna.

V “” so ukazi ali podatki, ki jih moraš prirediti za svoj router.
Če se boš povezoval preko SSH je ukaz sledeči:  ssh “user”@”ip mikrotik

Pod interfaces moraš pogledati kako imaš nastavljena dva parametra. Potrebuješ točno ime za WAN, npr. ether1 in LAN npr. ether2-master in potrebuješ še ime za bridge.

Urediš nastavitve za IGMP proxy
/routing igmp-proxy interface
add alternative-subnets=172.16.0.0/12 disabled=no interface=ether1 threshold=1 upstream=yes
add disabled=no interface=ether2-master threshold=1 upstream=no
add disabled=no interface=bridge threshold=1 upstream=no

sedaj se postavi z ukazom na pozicijo:
/routing igmp-proxy interface  

ukaz print pa ti mora izpisati tole:

Flags: X – disabled, I – inactive, D – dynamic, U – upstream

 #    INTERFACE                                        THRESHOLD                                                                                                                           

U ;;; T2 TV

ether1                                                       1

1    ;;; T2 TV

ether2-master                                       1

2    ;;; T2 TV

bridge-local                                           1

V kolikor imaš drugače nekaj nisi pravilno nastavil!

Nastavitve požarnega zidu:
/ip firewall filter
add action=accept chain=input comment=”Dovoli Broadcast” disabled=no dst-address-type=broadcast place-before=0

add action=accept chain=input comment=”Dovoli IGMP” disabled=no protocol=igmp place-before=0
add action=accept chain=input comment=”Dovoli T-2 IPTV” disabled=no protocol=udp src-address=172.16.0.0/12 place-before=0

In voila slika se mora prikazati….V kratkem spišem še kako deluje Kodi z T2 TV. Če ugotoviš izboljšave ali napake pa me prosim kontaktiraj.

Update: navodila T2 TV preko KODI s pomočjo Mikrotik routerja.